X9D won't bind

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Register
Jan 24, 2018
32
1
#1
I just updated my X9D using a Aloft preloaded SD card. After I did the updates firmware and bootloader non of my models were
bound. Tried to rebind the green light came on turned off bind plugged in receiver did not stay bound. Tried to update using Opentx
2.2.2 same result receivers do not stayed bounded. They all bind using my Hours. The X9D shows 2.2.2 firmware and 2.2.2 as the bootloader
Do you know a fix. Need help.
Thanks
Tom
 
Jan 24, 2018
32
1
#4
Here is what firmware is in the radio now.
FW: opentx - x9d
VERS: 2.2.2 (a5de713b)
DATE: 2018-07-28
EEPR: 218
UID: 001F0029 34324713 31373030
OTX Bootloader 2.2.2
Still need help
 
May 31, 2018
23
3
#5
Updating OpenTX will not change the bind state of any RX. If you are using D16 RXs then the model RX number must match so if you deleted and restored models it is possible that you restored a different RX number than the RX you are using is actually bound to. Re-binding the RX to the model should fix that but if you know it, correcting the RX number in the model should also work.

You must re-bind an RX to the a TX if you have bound it to another TX. That is you must start the RX with the bind button pressed and put the TX into BIND mode. You cannot normally bind an RX to more than one TX at once. If you bound your RXs to your Horus then you will need to re-bind them to the X9D before you can use them with the X9D TX. Once you do that they will not work with your Horus unless you re-bind them to that TX.

If it really is the case that when you try to bind an RX to a particular model by putting the RX in Bind mode and putting the TX in Bind mode, the RX does not bind, then there is either a mismatch between the XJT module firmware and the RX firmware (the EU thing) or there is something wrong with the XJT module.

It would possibly be helpful it you could say specifically which specific RX's you have tried and what exactly you did to try to "bind" the RX to the X9D.
 
Jan 24, 2018
32
1
#6
Thanks.
I reloaded Opentx 2.2.2 from the Opentx sight. Formatted the SD card reloaded the SD card content from the Opentx
sight. Tried your suggestions with a X8R diferent numbers no help. Also tried a D4R-II and a XM Micro SBUS and a
V8R7-II none of them bound. I tried the D4R-II and the V8R7-II on a Turnigy 9X with a frsky module they bound fine.
Rebound all four on my Horus the bound fine. This started when I updated my X9D and a friends Q7 with a Aloft Hobbies
Preloaded SD card, the Q7 did not bind to the XM micro in a Bind and fly quad from Aloft. Could the cards have been in
the wrong packages and caused this problem, just a thought. Any suggestions will be welcomed.
Thanks
Tom
 
May 31, 2018
23
3
#8
EU firmware is in the XJT and D16 RXs. You must have either FCC or EU in both for them to work together. Apart from flashing with known firmware or binding to a known good receiver there is no easy way to tell what version or region you have.

There is no EU version of OpenTX as such. The EU build option just removes the ability to select D8 as a protocol.
 
Feb 24, 2018
6
1
#11
Hi Tom C
I too am having the same issue with my x9d (not +) TX and a G-rx6 RX not binding. I am too using the preloaded sd card with 2.2.2 firmware, 2.2.2 bootloader, upgraded internal JXT module (although I'm wondering if the issue is that it is a x9d+ version? ??). I'm at my wits end and am now looking at an external XJT module to see if that works or in the radio settings trying the "reset to factory settings" and then reloading opentx 2.2.2 from there.
Is there a visible way to see if a RX is a EU/LBT version or international version, like a sticker or marking?
I swear the EU versions are a thorn in my side. WHY does Frsky have to have two versions??????
Just want to verify that Aloft Hobbies only sell international versions of the RX's, and not EU versions?
 
Last edited:
Jan 24, 2018
32
1
#12
Friday at 4:06 PM
#8



EU firmware is in the XJT and D16 RXs. You must have either FCC or EU in both for them to work together. Apart from flashing with known firmware or binding to a known good receiver there is no easy way to tell what version or region you have.

There is no EU version of OpenTX as such. The EU build option just removes the ability to select D8 as a protocol.

That's a answer I got. You need to ask Aloft if the X9+ firmware is the problem. Let me know what they say Post.
Sorry I am not more help.
Tom
 

Wayne

Administrator
Staff member
Nov 29, 2017
885
107
Novato, CA USA
#13
I think we are getting this radio in for some testing here. Will be interesting to see what we find with it. The firmware changes we are making with the OpenTX SD Card should have no effect on the binding of the radio as we are not touching the firmware for the internal XJT module. Very odd, but concerned now that 2 people have reported this issue!
 

Tom C

New member
Jan 24, 2018
32
1
#16
I get it packed up and sent soon. I don't want to put a lot of money in it. So let me know before putting parts in.
Thanks again
Tom