Installing multiprotocol module questions.

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Register

aben

New member
Feb 6, 2018
12
0
#1
I want to use an IRX4 multi module in my old Taranis X9D (not plus) version 1.1.02. After reading the problems some people are having with the set up I would like to ask how to find the best way to do this without messing up my settings and other things.
Thanks,
Ben
 
May 31, 2018
78
10
#2
First, unless you want to use your iR4 in ppm mode you need to update the OpenTX Firmware on your X9D to 2.2.2.

If you are still on 1.0 then you will need to use the power off "zadig(PC)/dfutil(MAC)" method
If you are on 2.X the you can also use the SD card or power on USB method which requires no driver setup bu requires you to update the bootloader as a separate step.

This is best done using OpenTX Companion since that way you can convert any existing models and the TX directly to 2.2.2. Otherwise it is more involved. Depending where you are starting you will have to redo Telemetry and the SD card content.

If you don't know what any of that means let me know and I can point you to some resources.
 

aben

New member
Feb 6, 2018
12
0
#3
PressAll,
Thanks for your response. I know what some of it means but not all, please send some resources.

Ben
 
May 31, 2018
78
10
#4
Set myself up for that one :)

First check the version of OpenTX your TX has...In the Radio Setup pages(long press ENTER) , page through to the Version page to see.
 
May 31, 2018
78
10
#6
you will need to use the power off method to update the firmware.


This is described quite well here...

http://open-txu.org/home/undergraduate-courses/


Make sure to back up the "models and settings" (aka eeprom) and the existing firmware before you change anything.

The important thing with Companion is to make sure to set the Radio Type in Settings->Settings...[Radio Profile] to match your radio and in particular, the X9D is different from X9D+. You also set the build options there before you download the firmware from OpenTX to your PC using File->Download... All unchecked is a reasonable default for most. You always chose differently and do it again if you find you need something. In 2.2 there are less options for the Taranis models so it is less error prone that it was in previous releases.


If you don't care about the models you can upgrade directly to OpenTX 2.2.2 If you do care about them then it is easiest to upgrade them using Companion. Just loading the backup should do it. Then you should be able to write the updated model file (originally .eepe, changed to .otx in 2.2) to your updated radio.


Note the upgrade just takes care of the format. You will have to fix up the various breaking changes. Briefly, for 2.1 telemetry has to be reprogrammed and the SD card sounds replaced. For 2.2 the SD card content has to be replaced. Any Custom content has to be adapted.


If you want to upgrade the models on the radio you will have to upgrade it through each major version of OpenTX (2.0, 2.1, 2.2 ) to preserve them. This can be done but it is a major pain since you need to get each version of Companion to download the firmware...or get the firmware from elsewhere.
 

Gerty64p

New member
May 3, 2018
29
1
#7
Im watching what is going on Here with this Module change im in a little better shape I have a QX7 and I am on 2.2.2
I went back in and redownloaded 2.2.2 but I put a CHECK Mark in the box for "Multi Protocol"
Im using this so I don't have to haul around my Spectrum TX only use it for Indoor Bind n Fly stuff
My concern now is that if im correct on this Spectrum doesn't use AETR sequence. So I am a little confused how I am going to make it work correctly with all my Bind n Fly planes
 
May 31, 2018
78
10
#8
The "FrSky" version of the multi-module firmware requires AETR channel order. If you bought the module wiht the FrSky option that's what you should have. It internally maps to the order expected by the protocol...TAER in the case of Spektrum. So set the Default Channel Order in the TX Radio Settings to AETR and you should be good when you make new models.

If you didn't get the module with the FrSky version of the firmware then it may get a bit confusing and it may be best to flash it with the "FrSky" firmware.

The other issue you might have is that Spektrum BNFs require about 80% of the FrSky throw. I'm not sure if the Multi-module compensates for that. It may depend on the firmware version.

I don't actually have one to test but the firmware information is all here...
https://github.com/pascallanger/DIY-Multiprotocol-TX-Module
 
Last edited:

aben

New member
Feb 6, 2018
12
0
#9
press and gerty,
Thanks press for the reply.
I also have a QX7 that I am trying to set up with a IRX4 6936 multi module. I upgraded the firmware using the Aloft loaded SD card to 2.2.2. The problem is that when I go to the model set up page on the QX7 there is no multi module option in the menu. What do I need to do to get it ?
Thanks,
Ben
 
May 31, 2018
78
10
#10
Aloft almost certainly ships his SD cards with the FrSky version of OpenTX and probably that does not include support for the multimodule. Note: The iRX4 is not certified for use in the US so this is not a recommendation that you should use it there. I don't know about other jurisdictions. Use your own judgement.

If you got the iRX4 with the protocol selector knob then you can use it in PPM mode

To get the direct muti-module support you need the "official" openTX version of 2.2.2. To get that you need to install Companion...
http://www.open-tx.org/

Goto Settings->Settings->[Radio Profile] , set the radio type for your radio (QX-7) and select the build options you want...Generally all unchecked is a good default but you want mulitmodule.
Then go to File->Download and download the Firmware...and possibly the SD card content to be sure it matches...FrSky have a habit of missing things when they make their OpenTX versions.

You can now flash the radio with the new firmware and replace the SD card content (may not be necessary) I would back up the one you have or better make a new one.

The easiest way is to copy the file to the SD card FIRMWARE folder (FIRMWARES prior to 2.2.X) and use the Radio' Bootloader mode. If you don't see the file the filename may be too long of your Bootloader and SD card versions don't match.
Restart the radio and update the bootloader by going to the same file in the SD card browser in the RADIO SETUP pages. Selecting it and pressing ENTER will get you a menu. Since you are already on 2.2, this is probably not necessary but I like to keep the versions in sync just in case.
 

aben

New member
Feb 6, 2018
12
0
#11
press,
Thanks for your information. It is interesting that the IRX4 is not certified in the US, it seems that a lot of people are using it. Mine is the one that has no knobs. I don't know if I can do what you suggest but maybe I can get some help. If you think of anything to add please let me know.
Ben
 

Gerty64p

New member
May 3, 2018
29
1
#12
Im using that IRX4 without the knob and it is Running all my DSM stuff just fine
I did not know it was Illegal to use that in the US I would suspect that the company did not run it thru the FCC acceptance procedure, I wonder also if the other stuff they make is NOT approved in the US? Doesn't that company make the IFLY Radio line