Firmware Update issues

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Register

JoeDawson

New member
Nov 3, 2018
3
0
#1
I was deep into OpenTX two years ago but I have been away for a while.
I had my radio (x9d) on 2.1.7 but today got the dust off it and tried to upgrade to 2.2.2.
I installed 2.2.2 Companion no issue but when I went to do the firmware I got this issue that said "new firmware not compatible with one currently installed".

I then downloaded 2.1.9 companion and installed 2.1.9 firmware and that went fine.

But on the jump to 2.2.2 I am getting this error.

No doubt I am missing a simple step... Please point out the error in my ways.

All the best,

Joe
 

JoeDawson

New member
Nov 3, 2018
3
0
#2
I just tried by un-selecting the option to confirm compatibility. I read somewhere that this option more checks to inform you that your changing a significant version... I did try to install with that off (just to see if it would) and it did... but when my radio restarted the screen was blank so I went back to 2.1.9. And that also lost all my models but because I had everything backed up I was able to restore all that.

Is it possible I have an OLD x9d that 2.2.2 is not supported? Mine is prior to the whole + stuff with vibration.
 

JoeDawson

New member
Nov 3, 2018
3
0
#3
I looked at that yesterday 100 times and didn't see the X9D+ on the Companion 2.2!
In Companion 2.1 it just said Taranis! Someone pointed this out to me on another forum this AM.
So Thanks to Kilrah on the OpenRC forums for making me go back and look again!
Feeling very stupid but happy I have it updated! :)
 

Wayne

Administrator
Staff member
Nov 29, 2017
885
107
Novato, CA USA
#4
Yep, that is what that warning was for. Always make sure you have selected the correct radio version in the Companion settings. This grabs the correct drivers for your screen and other hardware.

Sounds like you got it all going now. :)